<!DOCTYPE html> <html lang="en-US" xmlns:og="http://opengraphprotocol.org/schema/" xmlns:fb="http://www.facebook.com/2008/fbml"> <head><link rel="dns-prefetch" href="//ajax.googleapis.com">
<link rel="dns-prefetch" href="//www.google.com">
<link rel="dns-prefetch" href="//fonts.googleapis.com">
<link rel="preload" href="https://www.prairiepublishingmn.com/wp-content/cache/borlabs_cache/1/js/2ea42d4296fe208372e1608b3909be52b0d3eeb8_https.js" as="script">
<link rel="preload" href="https://www.prairiepublishingmn.com/wp-content/cache/borlabs_cache/1/css/9c2640fda6e261e30205bcfb339fc9aea64cbd0a_https.css" as="style">
<link rel="stylesheet" href="https://www.prairiepublishingmn.com/wp-content/cache/borlabs_cache/1/css/9c2640fda6e261e30205bcfb339fc9aea64cbd0a_https.css" type="text/css" media="all"><link href="https://fonts.googleapis.com/css?family=Oswald%3A400" rel="stylesheet"> <meta charset="UTF-8" /> <meta name="viewport" content="width=device-width, initial-scale=1.0" /> <meta http-equiv="X-UA-Compatible" content="IE=edge" /> <link rel="profile" href="https://gmpg.org/xfn/11" /> <link rel="pingback" href="https://www.prairiepublishingmn.com/xmlrpc.php" />   <!--[if lt IE 9]> <script src="https://www.prairiepublishingmn.com/wp-content/themes/bb-theme/js/html5shiv.js"></script> <script src="https://www.prairiepublishingmn.com/wp-content/themes/bb-theme/js/respond.min.js"></script> <![endif]--> <title>Winter sports now underway &#8211; Prairie Publishing</title>  <link rel='dns-prefetch' href='//ajax.googleapis.com' /> <link rel='dns-prefetch' href='//www.google.com' /> <link rel="alternate" type="application/rss+xml" title="Prairie Publishing &raquo; Feed" href="https://www.prairiepublishingmn.com/feed/" /> <link rel="alternate" type="application/rss+xml" title="Prairie Publishing &raquo; Comments Feed" href="https://www.prairiepublishingmn.com/comments/feed/" /> <link rel="alternate" type="application/rss+xml" title="Prairie Publishing &raquo; Winter sports now underway Comments Feed" href="https://www.prairiepublishingmn.com/2021/01/12/winter-sports-now-underway/feed/" /> <meta property="og:title" content="Winter sports now underway"/><meta property="og:type" content="article"/><meta property="og:url" content="https://www.prairiepublishingmn.com/2021/01/12/winter-sports-now-underway/"/><meta property="og:site_name" content="Prairie Publishing"/><meta property="og:image" content="https://www.prairiepublishingmn.com/wp-content/uploads/2021/01/lead-photo-1.jpg"/>                     <style id='wp-polls-inline-css' type='text/css'>
.wp-polls .pollbar {
	margin: 1px;
	font-size: 6px;
	line-height: 8px;
	height: 8px;
	background-image: url('https://www.prairiepublishingmn.com/wp-content/plugins/webads-polls/images/default/pollbg.gif');
	border: 1px solid #c8c8c8;
}

</style>                                                   <link rel='https://api.w.org/' href='https://www.prairiepublishingmn.com/wp-json/' /> <link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.prairiepublishingmn.com/xmlrpc.php?rsd" /> <link rel="canonical" href="https://www.prairiepublishingmn.com/2021/01/12/winter-sports-now-underway/" /> <link rel='shortlink' href='https://www.prairiepublishingmn.com/?p=202372' /> <link rel="alternate" type="application/json+oembed" href="https://www.prairiepublishingmn.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.prairiepublishingmn.com%2F2021%2F01%2F12%2Fwinter-sports-now-underway%2F" /> <link rel="alternate" type="text/xml+oembed" href="https://www.prairiepublishingmn.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.prairiepublishingmn.com%2F2021%2F01%2F12%2Fwinter-sports-now-underway%2F&#038;format=xml" />  <style type="text/css" media="screen">
	.g { margin:0px; padding:0px; overflow:hidden; line-height:1; zoom:1; }
	.g img { height:auto; }
	.g-col { position:relative; float:left; }
	.g-col:first-child { margin-left: 0; }
	.g-col:last-child { margin-right: 0; }
	.g-1 { margin:0px 0px 0px 0px;width:100%; max-width:300px; height:100%; max-height:250px; }
	@media only screen and (max-width: 480px) {
		.g-col, .g-dyn, .g-single { width:100%; margin-left:0; margin-right:0; }
	}
</style>   <script type='text/javascript' src='https://ajax.googleapis.com/ajax/libs/jquery/1.12.4/jquery.min.js?ver=1.12.4'></script><script type='text/javascript' src='https://www.google.com/recaptcha/api.js?ver=4.7.19'></script><script type="text/javascript" src="https://www.prairiepublishingmn.com/wp-content/cache/borlabs_cache/1/js/2ea42d4296fe208372e1608b3909be52b0d3eeb8_https.js"></script></head> <body class="post-template-default single single-post postid-202372 single-format-standard ecwd-theme-parent-bb-theme ecwd-theme-child-bb-theme-child fl-preset-color01 fl-fixed-width" itemscope="itemscope" itemtype="http://schema.org/WebPage"> <div> <div class="fl-page-bar"> <div class="fl-page-bar-container container"> <div class="fl-page-bar-row row"> <div class="col-md-8 hidden-sm text-left clearfix"> <div class="breakingNews" id="bn7"> <div class="bn-title"><h2>Breaking News</h2><span></span></div> <ul> <li><a href="https://www.prairiepublishingmn.com/2021/01/12/winter-sports-now-underway/">Winter sports now underway</a></li> </ul> <div class="bn-navi"> <span></span> <span></span> </div> </div>  <div class="fl-page-bar-text fl-page-bar-text-1"></div></div> <div class="col-md-4 col-sm-12 text-right clearfix"><ul id="menu-top-bar-menu" class="fl-page-bar-nav nav navbar-nav menu"><li id="menu-item-284" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-284"><a href="https://www.prairiepublishingmn.com/contact-us/">Contact Us</a></li> <li id="menu-item-285" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-285"><a>E-Editions</a> <ul class="sub-menu"> <li id="menu-item-24411" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-24411"><a target="_blank" href="http://1972.newstogo.us/editionviewer/default.aspx?Publication=d00f5e12-454b-41ff-9b04-a065261e9f5a">Madelia Times-Messenger</a></li> <li id="menu-item-24410" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-24410"><a target="_blank" href="http://1972.newstogo.us/editionviewer/default.aspx?Publication=f46e7d1e-2b78-405b-9cb4-0c8252e67498">Lafayette Nicollet Ledger</a></li> <li id="menu-item-24414" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-24414"><a target="_blank" href="http://1972.newstogo.us/editionviewer/default.aspx?Publication=fcaf6ff4-0baa-4cee-b75e-65afc77d4363">The Hanska Herald</a></li> <li id="menu-item-24413" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-24413"><a target="_blank" href="http://1972.newstogo.us/editionviewer/default.aspx?Publication=54279438-d2ff-4cf2-ac18-9302dd329472">Pure Gold</a></li> </ul> </li> <li id="menu-item-286" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-286"><a>Subscribe</a> <ul class="sub-menu"> <li id="menu-item-24417" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-24417"><a target="_blank" href="http://1972.newstogo.us/editionviewer/default.aspx?Publication=d00f5e12-454b-41ff-9b04-a065261e9f5a&#038;view=subscribe">Madelia Times-Messenger</a></li> <li id="menu-item-24416" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-24416"><a target="_blank" href="http://1972.newstogo.us/editionviewer/default.aspx?Publication=f46e7d1e-2b78-405b-9cb4-0c8252e67498&#038;view=subscribe">Lafayette Nicollet Ledger</a></li> <li id="menu-item-24419" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-24419"><a target="_blank" href="http://1972.newstogo.us/editionviewer/default.aspx?Publication=fcaf6ff4-0baa-4cee-b75e-65afc77d4363&#038;view=subscribe">The Hanska Herald</a></li> </ul> </li> <li id="menu-item-287" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-287"><a>Archives</a> <ul class="sub-menu"> <li id="menu-item-24422" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-24422"><a target="_blank" href="http://1972.newstogo.us/editionviewer/default.aspx?Publication=d00f5e12-454b-41ff-9b04-a065261e9f5a&#038;view=archives">Madelia Times-Messenger</a></li> <li id="menu-item-24421" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-24421"><a target="_blank" href="http://1972.newstogo.us/editionviewer/default.aspx?Publication=f46e7d1e-2b78-405b-9cb4-0c8252e67498&#038;view=archives">Lafayette Nicollet Ledger</a></li> <li id="menu-item-24425" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-24425"><a target="_blank" href="http://1972.newstogo.us/editionviewer/default.aspx?Publication=fcaf6ff4-0baa-4cee-b75e-65afc77d4363&#038;view=archives">The Hanska Herald</a></li> <li id="menu-item-24424" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-24424"><a target="_blank" href="http://1972.newstogo.us/editionviewer/default.aspx?Publication=54279438-d2ff-4cf2-ac18-9302dd329472&#038;view=archives">Pure Gold</a></li> </ul> </li> </ul><div class="fl-social-icons"></div></div> </div> </div> </div></div> <div class="fl-page"> <header class="fl-page-header fl-page-header-primary fl-page-nav-bottom fl-page-nav-toggle-button" itemscope="itemscope" itemtype="http://schema.org/WPHeader"> <div class="fl-page-header-wrap"> <div class="fl-page-header-container container"> <div class="fl-page-header-row row"> <div class="col-md-8 col-sm-8"> <div class="fl-page-header-logo" itemscope="itemscope" itemtype="http://schema.org/Organization"> <a href="https://www.prairiepublishingmn.com" itemprop="url"><img class="fl-logo-img" itemscope itemtype="http://schema.org/ImageObject" src="https://www.prairiepublishingmn.com/wp-content/uploads/2019/08/header3.png" data-retina="" alt="Prairie Publishing" /><meta itemprop="name" content="Prairie Publishing" /></a> </div> </div> <div class="col-md-4 col-sm-4"> <div class="fl-page-header-content"> <div id="search-2" class="widget widget_search pull-right"><form method="get" role="search" action="https://www.prairiepublishingmn.com" title="Type and press Enter to search."> <input type="text" class="fl-search-input" name="s" class="form-control" value="Search" onfocus="if (this.value == 'Search') { this.value = ''; }" onblur="if (this.value == '') this.value='Search';"> </form></div> </div> </div> </div> </div> </div> <div class="fl-page-nav-wrap"> <div class="fl-page-nav-container container"> <nav class="fl-page-nav navbar navbar-default" role="navigation" itemscope="itemscope" itemtype="http://schema.org/SiteNavigationElement"> <button type="button" class="navbar-toggle" data-toggle="collapse" data-target=".fl-page-nav-collapse"> <span>Menu</span> </button> <div class="fl-page-nav-collapse collapse navbar-collapse"> <ul id="menu-main-menu" class="nav navbar-nav menu"><li id="menu-item-1076" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-home menu-item-1076"><a href="https://www.prairiepublishingmn.com/">Home</a></li> <li id="menu-item-296" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-296"><a>E-Editions</a> <ul class="sub-menu"> <li id="menu-item-24400" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-24400"><a target="_blank" href="http://www.iclassifiedsnetwork.com/editionviewer/default.aspx?Publication=d00f5e12-454b-41ff-9b04-a065261e9f5a">Madelia Times-Messenger</a></li> <li id="menu-item-24399" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-24399"><a target="_blank" href="http://www.iclassifiedsnetwork.com/editionviewer/default.aspx?Publication=f46e7d1e-2b78-405b-9cb4-0c8252e67498">Lafayette Nicollet Ledger</a></li> <li id="menu-item-24403" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-24403"><a target="_blank" href="http://www.iclassifiedsnetwork.com/editionviewer/default.aspx?Publication=fcaf6ff4-0baa-4cee-b75e-65afc77d4363">The Hanska Herald</a></li> <li id="menu-item-24402" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-24402"><a target="_blank" href="http://www.iclassifiedsnetwork.com/editionviewer/default.aspx?Publication=54279438-d2ff-4cf2-ac18-9302dd329472">Pure Gold</a></li> </ul> </li> <li id="menu-item-297" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-297"><a>Subscribe</a> <ul class="sub-menu"> <li id="menu-item-24406" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-24406"><a target="_blank" href="http://www.iclassifiedsnetwork.com/editionviewer/default.aspx?Publication=d00f5e12-454b-41ff-9b04-a065261e9f5a&#038;view=subscribe">Madelia Times-Messenger</a></li> <li id="menu-item-24405" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-24405"><a target="_blank" href="http://www.iclassifiedsnetwork.com/editionviewer/default.aspx?Publication=f46e7d1e-2b78-405b-9cb4-0c8252e67498&#038;view=subscribe">Lafayette Nicollet Ledger</a></li> <li id="menu-item-24408" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-24408"><a target="_blank" href="http://www.iclassifiedsnetwork.com/editionviewer/default.aspx?Publication=fcaf6ff4-0baa-4cee-b75e-65afc77d4363&#038;view=subscribe">The Hanska Herald</a></li> </ul> </li> <li id="menu-item-58623" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-58623"><a href="#">Archives</a> <ul class="sub-menu"> <li id="menu-item-58618" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-58618"><a target="_blank" href="http://www.iclassifiedsnetwork.com/editionviewer/default.aspx?Publication=d00f5e12-454b-41ff-9b04-a065261e9f5a&#038;view=archives">Madelia Times &#8211; Messenger</a></li> <li id="menu-item-58617" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-58617"><a target="_blank" href="http://www.iclassifiedsnetwork.com/editionviewer/default.aspx?Publication=f46e7d1e-2b78-405b-9cb4-0c8252e67498&#038;view=archives">Lafayette Nicollet Ledger</a></li> <li id="menu-item-58620" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-58620"><a target="_blank" href="http://www.iclassifiedsnetwork.com/editionviewer/default.aspx?Publication=fcaf6ff4-0baa-4cee-b75e-65afc77d4363&#038;view=archives">The Hanska Herald</a></li> <li id="menu-item-58622" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-58622"><a target="_blank" href="http://www.iclassifiedsnetwork.com/editionviewer/default.aspx?Publication=54279438-d2ff-4cf2-ac18-9302dd329472&#038;view=archives">Pure Gold</a></li> </ul> </li> <li id="menu-item-58591" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-58591"><a href="#">Special Sections</a> <ul class="sub-menu"> <li id="menu-item-58615" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-58615"><a href="#">Business Profiles</a> <ul class="sub-menu"> <li id="menu-item-58614" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-58614"><a href="https://www.prairiepublishingmn.com/madelia-business-profiles/">Madelia Business Profiles</a></li> </ul> </li> <li id="menu-item-58595" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-58595"><a href="https://www.prairiepublishingmn.com/senior-living-healthcare/">Senior Living / Healthcare</a></li> <li id="menu-item-58594" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-58594"><a href="https://www.prairiepublishingmn.com/agriculture-today/">Agriculture Today</a></li> <li id="menu-item-58593" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-58593"><a href="https://www.prairiepublishingmn.com/holiday-gift-guide-2015/">Holiday Gift Guide 2015</a></li> <li id="menu-item-58592" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-58592"><a href="https://www.prairiepublishingmn.com/9-man-south-football-2016/">9-Man South Football 2016</a></li> <li id="menu-item-58605" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-58605"><a href="#">Visitors Guides</a> <ul class="sub-menu"> <li id="menu-item-202310" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-202310"><a target="_blank" href="https://www.iclassifiedsnetwork.com/editionviewer/default.aspx?Publication=aeaf374f-4d54-4233-9465-0b763d371588">Hanska Visitor&#8217;s Guide</a></li> <li id="menu-item-202311" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-202311"><a target="_blank" href="https://www.iclassifiedsnetwork.com/editionviewer/default.aspx?Publication=69c6c8a5-8839-41dc-b829-fdc06a5bbb51">Madelia Visitor&#8217;s Guide</a></li> </ul> </li> </ul> </li> <li id="menu-item-58369" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-58369"><a href="#">Public Notices</a> <ul class="sub-menu"> <li id="menu-item-58374" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-58374"><a href="https://www.prairiepublishingmn.com/madelia-times-messenger-public-notices/">Madelia Times Messenger</a></li> <li id="menu-item-58373" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-58373"><a href="https://www.prairiepublishingmn.com/lafayette-nicollet-ledger-public-notices/">Lafayette Nicollet Ledger</a></li> <li id="menu-item-58370" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-58370"><a href="https://www.prairiepublishingmn.com/the-hanska-herald-public-notices/">The Hanska Herald</a></li> </ul> </li> <li id="menu-item-26236" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-26236"><a href="https://www.prairiepublishingmn.com/advertising-rates/">Advertising Rates</a></li> <li id="menu-item-201073" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-201073"><a href="#">Pay A Bill</a> <ul class="sub-menu"> <li id="menu-item-26235" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-26235"><a href="https://www.prairiepublishingmn.com/pay-a-bill/">Madelia Times Messenger/Pure Gold/The Hanska Herald</a></li> <li id="menu-item-201075" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-201075"><a href="https://www.prairiepublishingmn.com/lafayette-nicollet-ledger/">Lafayette Nicollet Ledger</a></li> </ul> </li> </ul> </div> </nav> </div> </div> </header> <div class="fl-page-content" itemprop="mainContentOfPage"> <div class="webads-userbar-wrapper" style="display: none;"><span class="webads-userbar"><span class="webads-userbar-name"></span><span class="fl-sep"> | </span><a href="https://www.prairiepublishingmn.com/wp-admin/admin-post.php?action=webads_logout&webads_logout_nonce=DS9URN7DtQcxre6U"><span>logout</span></a></span></div>  <div class="container"> <div class="row"> <div class="fl-content fl-content-left col-md-9"> <article class="fl-post post-202372 post type-post status-publish format-standard has-post-thumbnail hentry category-breaking-news" id="fl-post-202372" itemscope="itemscope" itemtype="http://schema.org/BlogPosting"> <header class="fl-post-header"> <h1 class="fl-post-title" itemprop="headline"> Winter sports now underway </h1> <div class="fl-post-meta fl-post-meta-top"><span class="fl-post-author" itemprop="author" itemscope="itemscope" itemtype="http://schema.org/Person">By <a href="https://www.prairiepublishingmn.com/author/editor/" itemprop="url"><span itemprop="name">Editor</span></a></span><span class="fl-sep"> | </span><span class="fl-post-date" itemprop="datePublished" datetime="2021-01-12">January 12, 2021</span><span class="fl-sep"> | </span><span class="fl-comments-popup-link"><a href="https://www.prairiepublishingmn.com/2021/01/12/winter-sports-now-underway/#respond">0 <i class="fa fa-comment"></i></a></span></div><meta itemprop="image" content="https://www.prairiepublishingmn.com/wp-content/uploads/2021/01/lead-photo-1.jpg"><meta itemprop="interactionCount" content="UserComments:0"> </header> <div class="fl-post-content clearfix" itemprop="text"> <p><img class="aligncenter size-medium wp-image-202373" src="https://www.prairiepublishingmn.com/wp-content/uploads/2021/01/lead-photo-1-300x156.jpg" alt="" width="300" height="156" srcset="https://www.prairiepublishingmn.com/wp-content/uploads/2021/01/lead-photo-1-300x156.jpg 300w, https://www.prairiepublishingmn.com/wp-content/uploads/2021/01/lead-photo-1-768x398.jpg 768w, https://www.prairiepublishingmn.com/wp-content/uploads/2021/01/lead-photo-1-1024x531.jpg 1024w, https://www.prairiepublishingmn.com/wp-content/uploads/2021/01/lead-photo-1.jpg 1200w" sizes="(max-width: 300px) 100vw, 300px" /></p> <p>&nbsp;</p> <p>Winter sports now underway</p> <p>By Ruth Klossner</p> <p>&nbsp;</p> <p>After a six-week delay, practice for winter high school sports was finally allowed to begin Jan. 4.</p> <p>Nicollet Raider boys’ and Nicollet/Loyola girls’ basketball practice started at Nicollet and LCWM Area wrestling (including Nicollet athletes) started at Lake Crystal.</p> <p>As allowed by the Minnesota State High School League, the first games and meets can be held starting today. All three teams involving Nicollet athletes will open their seasons.</p> <p>The Nicollet/Loyola girls will open the season with a home game, facing GHEC/T/ML. The C-squad game is set for 4:30 p.m., with B-squad at 5:45 p.m. and varsity at 7:15 p.m. The Nicollet junior high girls will be at GHEC/T. Raider coaches are Jordan Rudenick, head coach; Sarah Strobel, assistant; and Anastasia Boever, junior high.</p> <p>The Raider boys’ basketball team will travel to St. Clair for its first game tonight. Game times are also 4:30, 5:45 and 7:15 p.m. The junior high boys will host St. Clair tomorrow night. Nicollet boys’ basketball coaches are Martin Stevens, head coach; Sid Brown, assistant; and Connor Theis, junior high.</p> <p>The LCWM Area wrestlers travel to LeSueur-Henderson today. Nate Meixell is the head wrestling coach.</p> <p>&nbsp;</p> <p>Boys basketball</p> <p>This year’s Nicollet Raiders boys’ basketball team has new faces on the bench. Taking over as head coach is Martin Stevens, with Sid Brown the new B-squad coach.</p> <p>Stevens played college ball at Bethany Lutheran College and has five years coaching experience at Mankato West, Mankato Loyola, and New Ulm Public. Brown played soccer at Bethany and coached basketball for a year at Mankato East.</p> <p>The new coaches are excited about their jobs.</p> <p>“The school, the principal, teachers, and some parents that I’ve met have all made me feel very welcome,” Stevens said. “And this is a great group of kids.”</p> <p>After a week of practice, Stevens is pleased with what he saw.</p> <p>“The kids were so excited to be here,” he said. “They brought the energy. I didn’t have to push them — they were ready to be out of the house!”</p> <p>As he began working with the team, Stevens noted that one of the first things he had to do was to get to know the kids — and for the kids to get to know him and to get in shape.</p> <p>“My philosophy is that I want to play a high tempo type game, implementing some changes defensively. They’ve played a lot of zone in the past — I want to employ more man defense this year,” he said.</p> <p>The team has a good amount of experience, with six seniors back.</p> <p>“They’ve done such a good job of how we practice. The past coaches built camaraderie — how together the guys are as a unit,” Stevens said.</p> <p>The Raiders have a lot of players that are long, lengthy, and athletic.</p> <p>“We have a lot of taller guys, which is good,” Stevens said.</p> <p>The coach knows a little about the conference and section and noted that St. Clair is always tough in the Valley and Waterville-Elysian-Mor-ristown in the section.</p> <p>“There are a lot of talented teams here. We’ll have to be ready. Every game will be tough. Everything will have to be earned. Teams won’t let us walk in and take a win — we’ll have to earn it.”</p> <p>Connor Theis is coaching the junior high teams. Those teams will have an uphill battle, as no eighth graders came out for basketball.</p> <p>To deal with that, Theis explained, “The plan is for sixth grade to play opponents’ seventh grade, and seventh grade to play eighth grade. This will force us to face tougher competition, but will also help the development of the players in the long run. The main thing is, we are having a season!”</p> <p>&nbsp;</p> <p>Girls basketball</p> <p>Even though the fan gallery will be limited, there will be lots of excitement in the north gym at Nicollet High School tonight — when the first sporting event in eight weeks will be played there.</p> <p>The Nicollet/Loyola girls will open the basketball season with a Valley Conference game, hosting Truman/Martin Luther/GHEC. Play will begin at 4:30 p.m. with the C-squad game, followed by B-squad and varsity.</p> <p>The Lady Raiders are coached by Jordan Rudenick, head coach; Sarah Strobel, B-squad; and Ana Boever, C-squad.</p> <p>Practice started Monday, Jan. 4. Rudenick reported, “The girls are happy to be practicing together. They have really good attitudes. They understand the situation we’re in, and they’re looking forward to making the most of it. They understand that they can’t take anything for granted. It’s one day at a time — we’re never sure because of COVID.”</p> <p>Jordan added, “It’s so good to have squeaky shoes in the gym again!”</p> <p>The Raiders have 22 ninth through 12th graders out for the sport, with 20 of them from Nicollet.</p> <p>“I’m happy with the numbers — we’ll have A, B, and C teams,” Rudenick said.</p> <p>The team has some experience back, as Rudenick explained. “My first five have a lot of experience from last year. Outside of that, there’s little varsity experience. The girls will have to grow quickly and get better in a hurry. It will be interesting to see how Olivia Whitmore, Emily Lorenz, and Hayley Selby play together in the post. Hayley is the most experienced of the group.”</p> <p>As the team gets going, the coach is moving some people around.</p> <p>“We have girls in different roles than where they saw themselves being, but they’ve accepted it. I think they’re just happy to be back together and playing basketball,” he said.</p> <p>As he looks ahead to the season, Rudenick expects that LCWM and St. Clair will be the pre-season favorites.</p> <p>“I hope that we find ourselves in the middle of the conference so that, when we get a chance to face them, we find ourselves in the conversation. We have to put the work in, show up, and play the games.”</p> <p>Alyssa Cassellius will coach the junior high girls’ team. She’ll have 13 players on her seventh and eighth grade teams.</p> <p>&nbsp;</p> <p>Wrestling</p> <p>Ten Nicollet wrestlers, along with ten from Lake Crystal Wellcome Memorial — wrestling together as LCWM Area — will hit the mat tonight, finally opening the 2020-21 wrestling season.</p> <p>They’ll be led by first year coach Nate Meixell.</p> <p>The coach stated, “Although this hasn’t been the most ideal way to start out my first season as head coach, due to COVID and all the delays we have had, I couldn’t be more excited to finally get the opportunity to coach this group of young men.”</p> <p>He went on, “We have had a great first couple days of practice where we are really trying to focus on fixing some bad habits and fine tuning our technique along with getting back into wrestling shape.”</p> <p>The LCWM wrestling team consists of six seniors, two juniors, four sophomores, two freshmen, four eighth graders, and two seventh graders. Ten letterwinners are back from last year’s roster — Griffin Gimenez, Tucker Wills, Seth Rosin, Nick Slater, Ean Gilman, Alex Harnitz, Brendan Jones, Jacob Tesch, Justin Slater, and Alex Sullivan.</p> <p>Meixell said, “I am looking forward to getting our season started as I believe we can really surprise some teams throughout the way. Our team captains have yet to be determined but our core group of seniors are really doing a great job of leading this team in the right direction.”</p> <div class="addtoany_share_save_container addtoany_content addtoany_content_bottom"><div class="a2a_kit a2a_kit_size_32 addtoany_list" data-a2a-url="https://www.prairiepublishingmn.com/2021/01/12/winter-sports-now-underway/" data-a2a-title="Winter sports now underway"><a class="a2a_button_facebook" href="https://www.addtoany.com/add_to/facebook?linkurl=https%3A%2F%2Fwww.prairiepublishingmn.com%2F2021%2F01%2F12%2Fwinter-sports-now-underway%2F&amp;linkname=Winter%20sports%20now%20underway" title="Facebook" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_twitter" href="https://www.addtoany.com/add_to/twitter?linkurl=https%3A%2F%2Fwww.prairiepublishingmn.com%2F2021%2F01%2F12%2Fwinter-sports-now-underway%2F&amp;linkname=Winter%20sports%20now%20underway" title="Twitter" rel="nofollow noopener" target="_blank"></a><a class="a2a_dd addtoany_share_save addtoany_share" href="https://www.addtoany.com/share"></a></div></div> </div> <div class="fl-post-meta fl-post-meta-bottom"><div class="fl-post-cats-tags">Posted in <a href="https://www.prairiepublishingmn.com/category/breaking-news/" rel="category tag">Breaking News</a></div></div> <div class="fl-comments"> <div id="respond"> <h3 class="fl-comments-respond-title">Leave a Comment</h3> <form class="fl-comment-form" action="https://www.prairiepublishingmn.com/wp-comments-post.php" method="post"> <label for="author">Name (required)</label> <input type="text" name="author" class="form-control" value="" tabindex="1" aria-required='true' /> <br/> <label for="email">Email (will not be published) (required)</label> <input type="text" name="email" class="form-control" value="" tabindex="2" aria-required='true' /> <br/> <label for="comment">Comment</label> <textarea name="comment" class="form-control" cols="60" rows="8" tabindex="4"></textarea> <br/> <div class="g-recaptcha" data-sitekey="6LdvRcMZAAAAAEXIplzSR6ZvSkSZTV1inA8BbwkV"></div> <br> <input name="submit" type="submit" class="btn btn-primary" tabindex="5" value="Submit Comment"/> <input type='hidden' name='comment_post_ID' value='202372' id='comment_post_ID' /> <input type='hidden' name='comment_parent' id='comment_parent' value='0' /> <div class="fl-comment-form-cancel"> <a rel="nofollow" id="cancel-comment-reply-link" href="/2021/01/12/winter-sports-now-underway/#respond" style="display:none;">Click here to cancel reply.</a> </div> </form> </div> </div> </article> </div> <div class="fl-sidebar fl-sidebar-right fl-sidebar-display-always col-md-3" itemscope="itemscope" itemtype="http://schema.org/WPSideBar"> <aside id="adrotate_widgets-2" class="fl-widget widget_adrotate_widgets"><!-- Either there are no banners, they are disabled or none qualified for this location! --></aside><aside id="adrotate_widgets-3" class="fl-widget widget_adrotate_widgets"><div class="a-single a-10"><a onClick="ga('send', 'event', 'Adverts', 'click', 'Breaking News Signup', 1.00, {'nonInteraction': 1});" href="https://www.prairiepublishingmn.com/breaking-news-signup/"><img onload="ga('send', 'event', 'Adverts', 'impression', 'Breaking News Signup', 2.00, {'nonInteraction': 1});" src="https://www.prairiepublishingmn.com/wp-content/uploads/2016/04/breakingNewsHeader.png" /></a></div></aside><aside id="webads_displayads_widget-2" class="fl-widget widget_webads_displayads_widget"> <style>
                    #displayAds img {
                        width: 100%;
                        height: auto;
                    }

                                        #displayAdsWrapper {
                        height: 1500px;
                        overflow: hidden;
                    }
                    

                </style> <div id="displayAdsWrapper"> <div id="displayAds"> <ul id="displayAdsUL"> </ul> </div> </div>  </aside> </div> </div> </div> </div> </div> <footer class="fl-page-footer-wrap" itemscope="itemscope" itemtype="http://schema.org/WPFooter"> <div class="fl-page-footer"> <div class="fl-page-footer-container container"> <div class="fl-page-footer-row row"> <div class="col-md-12 text-center clearfix"><div class="fl-page-footer-text fl-page-footer-text-1">This website is powered by <a href="http://www.websitesfornewspapers.com" target="_blank"><i><strong>WebsitesForNewspapers.com</strong></i></a></div></div> </div> </div> </div> </footer>            
</body></html>
<!--
Cached page generated by Borlabs Cache - more information https://borlabs.io/
Time to create cache: 1.92535281 sec
Time to load cache: 0.33875799
Cache file created on: 2021-01-13T01:51:34+00:00
Current time: 2021-01-13T02:23:41+00:00
-->